A more global fix for the Targeted Feedback issue is now live in the latest version of the Brisk extension (version 1.0.309+) To update immediately, uninstall and reinstall the extension (direct link).
If you've updated to version 309+ and are still experiencing issues, please reach out to hello@briskteaching.com
Resolved
A more global fix for the Targeted Feedback issue is now live in the latest version of the Brisk extension (version 1.0.309+) To update immediately, uninstall and reinstall the extension (direct link).
If you've updated to version 309+ and are still experiencing issues, please reach out to hello@briskteaching.com
Monitoring
A more global fix for the Targeted Feedback issue is now live in the latest version of the Brisk extension (version 1.0.309+) To update immediately, uninstall and reinstall the extension (direct link).
If you've updated to version 309+ and are still experiencing issues, please reach out to hello@briskteaching.com
Monitoring
We identified an issue that prevented Targeted Feedback from generating content in Google Docs for some users.
A fix is now live in the latest version of the Brisk extension (version 1.0.306+) To update immediately, uninstall and reinstall the extension (direct link).
Other Ways to Generate Feedback
Other feedback types in the Extension: Glows & Grows, Rubric Criteria, Next Steps
If you’re using Brisk in Google Docs, try switching Google accounts (click your profile icon in the top right).
You can also use Brisk on Microsoft Edge, the latest version is live there as well.
If you've updated to version 306+ and are still experiencing issues, please reach out to hello@briskteaching.com
Identified
We’ve identified an issue that’s preventing Targeted Feedback from generating content in Google Docs for some users. A fix has been submitted to the Chrome store and will share another update as soon as a new Extension update is ready to install.
If you’re experiencing issues, please reach out to hello@briskteaching.com
Other feedback types in the Extension, including Glows & Grows, Rubric Criteria, and Next Steps feedback.
Additional workarounds:
If you’re using Brisk in Google Docs, switching to a different Google account (click your profile icon in the top right) may resolve the issue temporarily.
Try installing the extension on Microsoft Edge, the fix is already live on the Edge store
Temporarily turning off other Chrome extensions while using Brisk can also sometimes resolve the issue.
Identified
We’ve identified an issue that’s preventing Targeted Feedback from generating content in Google Docs for some users. Our team is actively working on a fix and will share another update as soon as a new Extension update is ready to install.
If you’re experiencing issues, please reach out to hello@briskteaching.com
Other feedback types in the Extension, including Glows & Grows, Rubric Criteria, and Next Steps feedback.
Additional workarounds:
If you’re using Brisk in Google Docs, switching to a different Google account (click your profile icon in the top right) may resolve the issue temporarily.
Temporarily turning off other Chrome extensions while using Brisk can also sometimes resolve the issue.
Identified
The latest update fixed Targeted Feedback for most Google Documents, but some Google Documents embedded within Google Classroom and other LMSs that iframe Google Docs still seem to have an issue. If you are working within Google Classroom or similar LMS, try opening the student's document in a new tab to provide Targeted Feedback as a workaround.
Our team is continuing to investigate the Google Classroom-related issue with Targeted Feedback.
Monitoring
An updated version of the Brisk Chrome Extension is now available! Installing the latest version should resolve this issue.
If you are continuing to experience problems generating content or targeted feedback, please make sure you are on the most recent version by uninstalling and reinstalling the extension. You can find the extension by following this link: https://app.briskteaching.com/get-extension
Identified
We have identified the issue and we are working on a solution which will go out with the next Brisk Chrome Extension update. We will post another update when the Extension update is available to install.
For teachers experiencing issues with Targeted Feedback or Content Generation in Google Docs, here are workarounds for using Brisk:
Feedback can be generated with the following features: Batch Feedback, other Feedback types from the Extension including Glows & Grows, Rubric Criteria, and Next Steps feedback.
Content can be generated through Brisk's Web experience: https://app.briskteaching.com/.
In some cases, using Brisk on a Google doc logged into Google with a different account (using the icon in the upper right) may resolve the issue.
These issues are specific to the Chrome Extension, the Edge Extension is functional — log in to your Google account in the Edge Extension to use Brisk.
Investigating
We are investigating an issue where some teachers are not able to use the Brisk Chrome Extension, particularly using the Create or Targeted Feedback tools in Google Docs. This can show up as Brisk continuously showing a loading icon, not inserting feedback into a document, or stopping mid-creation.
If you're experiencing this issue, reach out to our team at hello@briskteaching.com for support and updates.